Author Topic: Deleting Entities  (Read 349 times)

DaKook

  • Crewmate
  • **
  • Posts: 23
  • "The Fool"
    • View Profile
Deleting Entities
« on: January 17, 2019, 04:14:10 PM »
Hey, I don't know if it's because I'm using VED and the VVVVVV level editor, but... MY ENTITIES KEEP GETTING DELETED!  :victoria:
It seems every time I load the level and play it from the beginning, one more entity is deleted! First a few script boxes, then an enemy, then a terminal... I don't know what's going on! Does anything like this happen for anyone else? And any info on how to maybe get it to stop?

Dav999

  • Global Moderator
  • Captain
  • *****
  • Posts: 2173
    • View Profile
    • The Open Level Project
Re: Deleting Entities
« Reply #1 on: January 17, 2019, 04:37:17 PM »
Hm, only thing I can think of right now is a bug in VVVVVV's own editor where hitting escape while creating a terminal or script box causes the wrong entity to be removed. There was also a bug in an older version of Ved where, under very specific circumstances, entities in the level might not be saved, but that only happened when deleting the first entity in the level file and if the stars were aligned in a certain way. And only if you were using a version from before July 2018.

So, other than that, I don't really know what's going on without a more precise description. If you can reproduce it yourself, it'd be nice to have a version of the level file before and after the fact, and what exactly you're doing in which editor before it happens.

DaKook

  • Crewmate
  • **
  • Posts: 23
  • "The Fool"
    • View Profile
Re: Deleting Entities
« Reply #2 on: January 17, 2019, 08:05:54 PM »
That does seem to be the problem; pressing escape to cancel terminals. Thanks! I'll be more careful about that.