Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - libfun

Pages: [1]
1
VVVVVV Tech Support / Re: Version 2: Report bugs here
« on: July 28, 2011, 08:01:07 pm »
I think you use .ogg files... If you would send me the .ogg files I could try to open it with a music player (foobar) and try if they work... If the problem occurs while playing the .ogg files directly via foobar this is a common problem in my system. If not the problem is somewhere in VVVVV... Would you aggree?

This might not help, cause foobar and game can use different decoders for .ogg audio files.

2
Well, I've found roots of the problem. It appears that game cannot run with libs from LIB32 or with ubuntu libs, so i've downloaded debain libs. So all you need is just copy /LIB32 from file attached to your game folder.

Here it is.

3
Here it is:
Code: [Select]
/VVVVVV$ LD_LIBRARY_PATH=./LIB32:$LD_LIBRARY_PATH ldd VVVVVV_32
linux-gate.so.1 =>  (0xb789f000)
libSDL_mixer-1.2.so.0 => ./LIB32/libSDL_mixer-1.2.so.0 (0xb7845000)
libSDL_image-1.2.so.0 => ./LIB32/libSDL_image-1.2.so.0 (0xb7828000)
libSDL-1.2.so.0 => ./LIB32/libSDL-1.2.so.0 (0xb779c000)
libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xb7699000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xb7673000)
libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xb7657000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xb74f6000)
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xb74dc000)
libmikmod.so.2 => /usr/lib/libmikmod.so.2 (0xb7490000)
libvorbisfile.so.3 => ./LIB32/libvorbisfile.so.3 (0xb7487000)
libsmpeg-0.4.so.0 => /usr/lib/libsmpeg-0.4.so.0 (0xb7433000)
libjpeg.so.62 => /usr/lib/i386-linux-gnu/libjpeg.so.62 (0xb7413000)
libtiff.so.4 => /usr/lib/i386-linux-gnu/libtiff.so.4 (0xb73b7000)
libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xb73a2000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xb739e000)
libpulse-simple.so.0 => /usr/lib/libpulse-simple.so.0 (0xb7399000)
libpulse.so.0 => /usr/lib/libpulse.so.0 (0xb7358000)
/lib/ld-linux.so.2 (0xb78a0000)
libvorbis.so.0 => ./LIB32/libvorbis.so.0 (0xb7330000)
libogg.so.0 => ./LIB32/libogg.so.0 (0xb7329000)
libpulsecommon-0.9.22.so => /usr/lib/libpulsecommon-0.9.22.so (0xb72e0000)
librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xb72d7000)
libX11-xcb.so.1 => /usr/lib/i386-linux-gnu/libX11-xcb.so.1 (0xb72d4000)
libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xb71b8000)
libICE.so.6 => /usr/lib/i386-linux-gnu/libICE.so.6 (0xb71a0000)
libSM.so.6 => /usr/lib/i386-linux-gnu/libSM.so.6 (0xb7198000)
libXtst.so.6 => /usr/lib/libXtst.so.6 (0xb7192000)
libxcb-atom.so.1 => /usr/lib/libxcb-atom.so.1 (0xb718d000)
libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xb7173000)
libdbus-1.so.3 => /lib/i386-linux-gnu/libdbus-1.so.3 (0xb7136000)
libwrap.so.0 => /lib/libwrap.so.0 (0xb712d000)
libsndfile.so.1 => /usr/lib/libsndfile.so.1 (0xb70c6000)
libuuid.so.1 => /lib/i386-linux-gnu/libuuid.so.1 (0xb70c1000)
libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xb70b1000)
libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xb70ad000)
libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xb70a7000)
libnsl.so.1 => /lib/i386-linux-gnu/libnsl.so.1 (0xb7090000)
libFLAC.so.8 => /usr/lib/libFLAC.so.8 (0xb7044000)
libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0xb6ecb000)

4
Seems to me the supplied libs aren't being used in the first place (see here). Try this:
Code: [Select]
mv LIBS64 LIB64
for file in LIB32/* LIB64/*; do ln -s `basename $file` ${file%.*.*}; done

This didn't help either.

5
Same problem in Ubuntu 11.04. Removing libs doesn't help.

Pages: [1]