Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - seamoose

Pages: [1]
1
VVVVVV Tech Support / Re: Linux VVVVVV audio problems & SIGFPE
« on: July 27, 2011, 12:35:52 am »
Thanks for the prompt response!

After reading the post "Immediate SEGFAULT on Linux" by TechMage89,
I moved the VVVVVV-supplied SDL libraries out of LIB32, forcing VVVVVV
to use the system-supplied SDL libraries. This solved both my audio problem
and the SIGFPE.

Now off to save the crew!

2
VVVVVV Tech Support / Linux VVVVVV audio problems & SIGFPE - SOLVED
« on: July 26, 2011, 11:52:23 pm »
Just purchased VVVVVV with the HIB. I'm running Debian 6,
and when I try to start VVVVVV I get:

$ ./VVVVVV
Levels will be saved to: /home/simos/.vvvvvv/
The save directory exists at: /home/simos/.vvvvvv/
[Cute ASCII graphics]
Unable to initialize audio: %s
No available audio device
Unable to load WAV file: %s
Audio device hasn't been opened
Unable to load WAV file: %s
Audio device hasn't been opened
Unable to load WAV file: %s
[...]

Tried running a trace and I suspect it's trying to use PulseAudio
for sound. Some of us have had enough of PulseAudio and are
using ALSA. If this is indeed the problem, is there any way to
either force VVVVVV to use ALSA or provide a command-line
option to use ALSA?

Also, once I get to the main screen and press the "Action" key,
it dies with a SIGFPE:

[...]
rt_sigaction(SIGQUIT, {SIG_DFL, [], 0}, NULL, 8) = 0
tgkill(10387, 10387, SIGFPE)            = 0
sigreturn()                             = ? (mask now [])
--- SIGFPE (Floating point exception) @ 0 (0) ---
+++ killed by SIGFPE +++
Floating point exception

I can provide any other debugging info needed.

Thanks for making a Linux version - looking forward to playing it!

Pages: [1]