Savegame problem (NOT THE CCLEANER ONE)

Started by djalmax, February 20, 2010, 11:22:50 PM

Previous topic - Next topic


So hello guys. I bought the game like a week ago and I'm having a big problem, I was losing my savegames and for once I though it was CCleaner fault so I set everything right to prevent ccleaner from cleaning my savedgames. But I realized that it's not ccleaner's fault...everytime I turn off my computer when I turn it on again all my savegames are gone. Even when I don't use ccleaner at all! What should I do, I can't start from the beginning all my life. Please help, thanks in advance and sorry for poor english!


It sounds like something is deleting your saves alright :( It's not a default setting; it's something you have to consciously set up! Are you using the firefox browser plugin "BetterPrivacy", maybe? Is there anything you might be using that routinely clears your flash cache?


Not that i'm aware of, I use Google Chrome.


Check the cookie saving on Google Chrome.
It may be set to clear cookies it doesn't recognize.
Also if I remember correctly there is a way to set it up to delete history everyday or something to that extent( for privacy reasons) which for some reason it generally includes cookies and a few other things.  If you set it up to do that it will probably delete your cookies.


I don't understand what the cookies have to do with the savegame problem, I don't know much about this flash thing. I'm playing in my computer, not in the browser. I'm getting really desperate now, 'cause it seems I'm not even close to solving this problem, none of the tips worked.


Flash cookies are made with every flash game. Whether you play in a browser or not.

BetterPrivacy and CCLeaner and others delete these

tell us ALL of the programs you're using. Chrome doesnt delete those flash cookies and neither does firefox (only with a plugin)

did you add flash folder to the exclude list in ccleaner?

also, try this page:


Well, I use Ccleaner and I excluded the flash folder to prevent any lost of data. I also use advanced systemcare. I don't think there's anymore stuff. Maybe there's something installed in my computer that is ruining my savedgames and I don't even know what it may be. I had the same problem with Machinarium, but only by fixing the CCleaner problem it worked, but for VVVVVV nothing seems to work. As I said I use google Chrome and Internet Explorer as well.


It really sounds like CCleaner is the most likely culprit here... I'd try turning it off and restarting, just to make sure.

If that is the problem, do a search for "dwvvvvvv_unlock.sol", and make sure whatever folder it's in is excluded from CCleaner.


I already did that! I excluded not only the folder of this archive but even the own archive.


Oh dear... :(

I don't know how much I can do to help here - the only explanations are that you've got something installed or setup or some sort of shutdown script which clears your flash cache, or you've set your computer not to store flash cookies at all (which probably isn't the case).

A brute force solution, seeing as it only deletes when you shutdown, is to make a backup and replace when you want to play. You could probably write a .bat file to do this for you; something like this: (create a directory called vbackup on your c drive)


copy "c:\Documents and Settings\Terry\Application Data\VVVVVV\Local Store\#SharedObjects\VVVVVV.swf\dwvvvvvv_unlock.sol" c:\vbackups\dwvvvvvv_unlock.sol
copy "c:\Documents and Settings\Terry\Application Data\VVVVVV\Local Store\#SharedObjects\VVVVVV.swf\dwvvvvvv_tele.sol" c:\vbackups\dwvvvvvv_tele.sol
copy "c:\Documents and Settings\Terry\Application Data\VVVVVV\Local Store\#SharedObjects\VVVVVV.swf\dwvvvvvv_quick.sol" c:\vbackups\dwvvvvvv_quick.sol


copy c:\vbackups\dwvvvvvv_unlock.sol  "c:\Documents and Settings\Terry\Application Data\VVVVVV\Local Store\#SharedObjects\VVVVVV.swf\dwvvvvvv_unlock.sol"
copy c:\vbackups\dwvvvvvv_tele.sol "c:\Documents and Settings\Terry\Application Data\VVVVVV\Local Store\#SharedObjects\VVVVVV.swf\dwvvvvvv_tele.sol"
copy c:\vbackups\dwvvvvvv_quick.sol "c:\Documents and Settings\Terry\Application Data\VVVVVV\Local Store\#SharedObjects\VVVVVV.swf\dwvvvvvv_quick.sol"

If you find the culprit that's deleting your flash cache, let us know, ok?


A quick search of google shows that advanced systemcare will also remove flash cookies. I have no experience with the program but you should dig through the settings and disable the option or add the folder to exclude.


Quote from: allen on February 22, 2010, 10:20:36 PM
A quick search of google shows that advanced systemcare will also remove flash cookies. I have no experience with the program but you should dig through the settings and disable the option or add the folder to exclude.

Yeah, my friend came up to my house and helped me. It really was advanced systemcare, the software has a default setting that delete flash files. I set everything right and it's working properly now. My savegames are safe and I can play normally now hehe. Thanks everyone. :P