Uhh... is this supposed to happen?

Started by SteveGamer68, December 14, 2017, 02:44:12 PM

Previous topic - Next topic


I was playing VVVVVV on mobile. At the end, i attempted the "Teleport ship bug" (Which i can't find). But instead of teleporting, i open the screen after the first flash (which enables the option to warp to ship) Then close it. I got teleported like normal, then something happend:
Instead of Popular Potpourri playing, Piercing the Sky plays instead. After the credits and stuff, i come back and activate Popular Potpourri by jukebox (Yes i have 20 trinkets), the same thing happend.

Is this supposed to happen? Did anyone get this similar effect? I don't think doing that bug caused it.

(BTW, i tried close and reloading and the same effect happend.)


Can you send a screenshot of what the teleporter glitch is?


I would need to make a .gif to show how it works, not a .png . But i can explain the glitch:
1. You beat the game by going to Outer Space
2. Go through the Game complete! screen
3. Wait until the first flash
4. Your CREW option will become SHIP before you even teleported there.
5. Click teleport (or not)
6. If not clicked teleport, you will be send to the ship by your crew. If you DO teleport, in the PC version, you got stuck there. Not sure about mobile though, because i don't teleport. I insteas waited for the crew to "rescue" me.

BTW, i tested it on the PC version, and the bug doesn't seem to appear.


I tried reproducing this on the Switch version and the glitch didn't occur.


Apparently, in the Android version, there wasn't enough space for both Piercing The Sky and Popular Potpourri so they made Piercing The Sky play where PP usually would.


That means:
Happy music -> Epic music
Anyways, so it WAS intentional.