Author Topic: 64bit Linux library problems with version 2.01  (Read 1841 times)

PJBrs

  • Crewmate
  • *
  • Posts: 1
    • View Profile
64bit Linux library problems with version 2.01
« on: August 15, 2011, 09:18:44 am »
Dear developers, first of all, thanks for bringing VVVVVV to linux! I've played it for about half an hour now and it is a lot of fun!

I have trouble starting VVVVVV on 64 bit linux. When I manually choose to start VVVVVV_64 there's no problem, so there appears to be a problem with the libraries shipped with VVVVVV-2.01. Running ldd on every 64-bit library that was shipped with VVVVVV, it appears that the following libraries are missing:  libpulse-simple.so.0, libpulse.so.0, and libtiff.so.4. I was able to solve the warning about libtiff by softlinking to the (older) libtiff version that was included with my distribution (Slackware 13.1). I don't have a distro package for libpulse or libpulse-simple.

Funnily enough, if I just run ldd on the VVVVVV_64 binary, all dependencies appear to be met by the system libraries, and indeed, VVVVVV seems to run fine if I run VVVVVV_64 directly. The real problem seems to be in the libSDL-1.2.so.0 that was shipped with VVVVVV (requires libpulse-simple.so.0 and libpulse.0) and libSDL_image-1.2.so.0 (requires libtiff.so.4). If I remove libSDL-1.2.so.0 and libSDL_image-1.2.so.0 from the VVVVVV/LIB64 directory I can start VVVVVV normally.

I don't know how you might solve this, but it seems to me that you have either shipped too many or too few libraries, at least for VVVVVV to run in Slackware 13.1. Maybe you can solve this problem?