Author Topic: Bug Reports Go Here  (Read 35029 times)

Mercen4ry

  • Crewmate
  • **
  • Posts: 25
    • View Profile
Re: Bug Reports Go Here
« Reply #45 on: January 18, 2010, 01:11:05 am »
I went back and looked. Seeing as I missed that thread, and completely didn't pay attention to the spikes, point rescinded. ;)

Thanks for the follow-up. :)

The Brass

  • Professor
  • ****
  • Posts: 137
    • View Profile
Re: Bug Reports Go Here
« Reply #46 on: January 18, 2010, 12:42:13 pm »
Bam.

Go next to any character, press enter and then immediately esc into the menu. When you start another game anywhere, you can keep talking to the character. In the normal modes attempting to talk again usually results in being teleported away. But in time trial, he/she stays there and even if you walk away, you can talk when you come back, unless you leave the room.

Doing this with 20-trinket Victoria and the final level time trial has hilarious consequences.

drknow

  • Crewmate
  • *
  • Posts: 1
    • View Profile
Re: Bug Reports Go Here
« Reply #47 on: January 19, 2010, 10:33:38 am »
Just played through the demo... game looks brilliant so far!

Only thing I've found wrong (and believe me, I've looked!) is the room name "Exausted?"

This is probably supposed to have an 'h' and be spelled "Exhausted?", right?

Can't wait to play the rest!! :D

The Brass

  • Professor
  • ****
  • Posts: 137
    • View Profile
Re: Bug Reports Go Here
« Reply #48 on: January 19, 2010, 09:01:20 pm »
Well, this is serious. :verdigris:

http://i328.photobucket.com/albums/l321/MutoidLog/trinkets.jpg

I'm not sure of the exact requirements, but it does happen when you go to Victoria's room the first time with 19 trinkets, her having the last one. After Viridian's monologue, do the enter+esc with Victoria and then go to a time trial. Not only do the graphics screw up, but you get a whopping two extra trinkets. While it's only hilarious in the final level (world record: 3/1 trinkets!) and makes you miss the par in The Tower, the impact is huge on all other stages. This makes getting V much easier...  :victoria:

Terry

  • Administrator
  • Captain
  • *****
  • Posts: 607
    • View Profile
    • distractionware
Re: Bug Reports Go Here
« Reply #49 on: January 19, 2010, 10:56:00 pm »
:vitellary:

I suspect that's a relative of the whole not-resetting the script problem when exiting the game, but I didn't realise that it would cause any game breaking problems. I'll catch it in the update.
« Last Edit: January 19, 2010, 11:20:05 pm by Terry »

Terry

  • Administrator
  • Captain
  • *****
  • Posts: 607
    • View Profile
    • distractionware
Re: Bug Reports Go Here
« Reply #50 on: January 20, 2010, 06:55:16 pm »
Ok! Here's a list of things I'm going to add/fix for the first patch:

  • Support more flexible graphical options; enable/disable screen smoothing, hardware acceleration, manual screen zooming as individual options.
  • Allow the player to relock things from the unlock menu; clarify the purpose of the menu.
  • Add a quick restart button to the time trials.
  • Make Viridian sad if he's missed the par time on a time trial.
  • Game will default to a window to allow linux users to play the windows version through WINE or CrossOver.
  • Warping back to ship from tower breaks the game.
  • Final level room names don't reset as they should.
  • Room names in menu bar aren't reported properly for final level "glitch" and "change" rooms.
  • Minor room name issue if you quit the intermission stages from the menu.
  • Trying to quit during the Gravitron bug.
  • "If wonder what we'll find?"
  • Prize for the reckless platform glitch.
  • Scripts are not reset when restarting the game (if you quit during a cutscene, the cutscene will continue when you start a time trial or other game mode).
  • Possible issue with teleporter-one flag not being set if you revisit the first space station level?
  • Is No Death Mode overwriting saves? It shouldn't be! Investigate!
  • Quicksaving in the tower doesn't default to the correct camera position.
  • Room death counts should be reset on game start.
  • 21st Trinket bug.
  • Teleporter cutscene mix up if playing in no death mode
  • It's possible to bring up the menu from the "game complete" screen, and break the game if you try to teleport back to the ship this way.

There are a few other reported issues that are just a result of the way the standalone flash player works, and unfortunately aren't really things I can fix...

Hoping to have the linux version and first patch released together. If there's anything on that list I've missed, please let me know!
« Last Edit: January 24, 2010, 02:00:04 pm by Terry »

Boco

  • Crewmate
  • *
  • Posts: 5
    • View Profile
Re: Bug Reports Go Here
« Reply #51 on: January 20, 2010, 08:46:51 pm »
Ok! Here's a list of things I'm going to add/fix for the first patch:
I assume from this list that the slipperiness is intentional and won't change in the future?

Terry

  • Administrator
  • Captain
  • *****
  • Posts: 607
    • View Profile
    • distractionware
Re: Bug Reports Go Here
« Reply #52 on: January 20, 2010, 08:56:32 pm »
There is some horizontal inertia in the character's movement, but the "slipperiness" you seem to be talking about is an issue with flash on your system that I'm not able to fix. Sorry.

Terry

  • Administrator
  • Captain
  • *****
  • Posts: 607
    • View Profile
    • distractionware
Re: Bug Reports Go Here
« Reply #53 on: January 21, 2010, 09:19:14 pm »
Fun times!  I was playing through Undying and made it to Space Station 2 before dying.  I continued, and it loaded my undying game--in which I had skipped most of the trinkets.  Consequently, I didn't have any of them.  I played through, went back, got the trinkets... and still only had 18!  I scratched my head and realized I'd forgotten the ones in the starting area.

After going back into the Space Station 1 teleporter to work my way backwards... Veridian promptly said, "A teleporter! I can get back with this!"  I went into Quicksand, and the game hint to use arrows for flipping popped up.  I went into Trench Warfare and got the cutscene regarding trinkets.  When I got my trinkets and went back through the teleporter, it brought up the cutscene with Violet and told me that I'd completed the level and finally rescued all my crewmen.  Except the others were now missing.

I had 20 trinkets and no crewmates.  Weird.

Just encountered this one myself... Very strange! I think I know what the problem is. Added it to the list.

Applekid

  • Doctor
  • ***
  • Posts: 41
    • View Profile
Re: Bug Reports Go Here
« Reply #54 on: January 22, 2010, 01:40:49 am »
Found one: Starting a new game in invincibility mode works, but, after saving and coming back, it forgets that you were invincible for that play-though.

krizoitz

  • Crewmate
  • *
  • Posts: 3
    • View Profile
Re: Bug Reports Go Here
« Reply #55 on: January 23, 2010, 07:29:58 am »
So I tried redownloading and re-installing.  Didn't help.
Tried installing the latest version of Flash and restarting the computer.  Still not helping.

So basically at this point I can play through to the first teleporter and thats it.  If I quit, I have to start over.

Relevant technical info:

Mac OS 10.6.2
Flash version 10.0.42.34
vvvvvv version 10.0.42.34
vvvvvv created date and time: Wednesday, November 11, 2009 4:23 AM

I'd really love to be able to play the game, please help!  :victoria:


Mac version bugs:

1. Game stops upon reaching the first teleporter
2. Quiting the game all saves are gone.


Those are interesting bugs... I've never had those happen with my mac... strange.

Terry

  • Administrator
  • Captain
  • *****
  • Posts: 607
    • View Profile
    • distractionware
Re: Bug Reports Go Here
« Reply #56 on: January 23, 2010, 11:59:19 am »
krizoitz: I don't know what exactly, but there is something up when flash tries to write to your local storage cache. Have you disabled it? Try another flash game (not VVVVVV), right click on it and go to properties and make sure you're allowing some storage space...

krizoitz

  • Crewmate
  • *
  • Posts: 3
    • View Profile
Re: Bug Reports Go Here
« Reply #57 on: January 24, 2010, 06:17:38 am »
krizoitz: I don't know what exactly, but there is something up when flash tries to write to your local storage cache. Have you disabled it? Try another flash game (not VVVVVV), right click on it and go to properties and make sure you're allowing some storage space...

PERFECT!  Made it to the next level with no sign of wonky behavior!  Not sure how it happened, but thanks for the fix!

Terry

  • Administrator
  • Captain
  • *****
  • Posts: 607
    • View Profile
    • distractionware
Re: Bug Reports Go Here
« Reply #58 on: January 24, 2010, 11:56:16 am »
Oh, excellent! :viridian:

Shasharala

  • Professor
  • ****
  • Posts: 194
  • Black tea, green tea, red tea, white tea...
    • View Profile
    • Fur Affinity Profile
Re: Bug Reports Go Here
« Reply #59 on: January 27, 2010, 03:44:44 am »
You know how in the tower since it scrolls if you save and then reload you die before the screen scrolls up to where you are?
Well not sure if you already found out, but it happens in any of the scroll rooms.  Which makes sense, I guess.
So the room called The Final Challenge and one other in the level where Viridian goes missing also need to be adjusted.
Umm... probably a few other scrolling rooms i can't think of...